Thursday, April 12, 2007

Ubuntu subversion upgrade to 1.4.3 HowTo for x86_64

This was really irritating me to no end! I work in Eclipse with a subversion plugin that took my project checkouts into the subversion 1.4.3. When I tried to command line any of the 'svn' commands I would get the lovely message that I had a client that was too old (Ubuntu Edgy gives me subversion 1.3.2). Fixing that by upgrading my subversion installation (condensed from Ubuntu Forums) was as follows:

# get subversion tarballs and unpack.
#
$ wget http://subversion.tigris.org/downloa...n-1.4.3.tar.gz
$ wget http://subversion.tigris.org/downloa...s-1.4.3.tar.gz
$ tar xvzf subversion-1.4.3.tar.gz
$ tar xvzf subversion-deps-1.4.3.tar.gz

# setup tools and deps.
# 
$ aptitude install build-essential
$ aptitude install libapr1 libapr1-dev libaprutil1 libaprutil1-dev
$ aptitude install libneon25 libneon25-dev
$ aptitude install libdb4.3 libdb4.3-dev   \
db4.3-util libdb4.3++c2 libdb4.3++-dev
$ aptitude install checkinstall auto-apt

# apply an x86_64 fix to the neon makefile. 
# Change line with 'CFLAGS' to read:
#
#  CFLAGS= -g -O2 -fPIC
# 
# do this AFTER the ./configure run!
$ vim neon/src/Makefile

# build and install!
#
$ auto-apt run ./configure --with-ssl   \
--with-apr=/usr/bin/apr-config        \
--with-apr-util=/usr/bin/apu-config
$ make
$ checkinstall